28: Flight Instrument Panel Tweak – Part 1

Saitek Pro Flight Instrument Panel

Saitek’s Pro Flight Instrument Panel (FIP) comes with an XML file that defines the order of gauges to be shown when starting up.  The default order is:

Altimeter<-> Airspeed<-> Attitude
<->  Compass <-> Turn Indicator <->  Vertical Speed

This order is also true to the sequence of gauge starting when more than one FIP are included in the system.  By editing the XML file, the order of the six gauges to be shown can be arranged as desired.

Here are the steps:

1) Go to C:\Program Files (x86)\Saitek\DirectOutput directory and locate SaiFlightSimX.xml

2) Make a backup of the XML file for safety purpose.

3) Open the XML file with Notepad.

4) In the file, there are six <Gauge Timeout= >……</Gauge> sections

5) The first line of each section represents a specific gauge:

6) Rearrange these six gauges (whole section or just the first line) into the order of your choice.  The earlier the position of the specific gauge is in the file, the earlier it will show up when the FIP is activated.

7) When done, save and exit the file.

The next time the FIP is activated, the gauge(s) will appear in the order just set.

===========================================
Additional Tweak – Remove Saitek Product Images

When FIP is activated before FSX is loaded or after FSX is exited, it will alternately display the serial number of the FIP and Saitek’s other Pro Flight product images.   You can delete these advertising images (not the serial number one) or replace them with your own pictures if you don’t like them.

Just go to  C:\Program Files\Saitek\DirectOutput directory and remove all jpg images named Fip(1-5).  It is advisable to move these images to a backup folder just in case they are needed in the future.

These images are having a dimension of 320 x 240.   They can be replaced by pictures having the same spec and using the same Fip naming.

Note: Windows 7 64-bit system has both Program Files and Program Files (x86) directories for 64-bit and 32-bit applications respectively.  If a 32-bit windows is involved, locations of files mentioned above may vary.

Advertisements

46 thoughts on “28: Flight Instrument Panel Tweak – Part 1

  1. Dear Tom,

    I use 10 FIP’s and they all start up before FSX starts to run.
    I have changed the sequence of the Gauges to be shown by adjusting the XML file like your example.
    But for some reason the FIP’s still start-up at random.
    Do you have a solution for this?
    I have also attached my XML file .
    Thanks in advance for your assistance.
    Kind regards, Cor Rademaker

    Like

    1. You have two options, Cor.

      1) Plug in the FIPs after FSX starts up. See my Post 194.
      This is the easiest and safest. I’ve been taking this approach for a long time without any issue.

      2) Update to the new Saitek drivers. This one solves the issue for good.
      BUT NOTE that the installation could be tricky. If you are lucky, the installation is simple and quick.
      If you are not, then you need some technical knowledges to make the new drivers work. See my Post 305 and 306.
      Also, wouldn’t recommend you to take the 2nd option if you don’t have system backup software that would allow you to restore your computer to the state before the new Saitek drivers installed, just in case you can’t manage to make the new drivers work.
      Tom

      Like

  2. Hi Tom!
    I have two PC connected in a LAN and I use a set of 6 instruments connected using SimConnect in the “slave” machine. The Saitek guide to do this says that both PCs must be running the FIP drivers. My question is… in witch of them I need to modify the xml file ? Other is… I can only start the saitek exe on the slave machine if the fsx is already running in the master pc and the instrumens is already connected to the slave pc. How to solve this ?

    Like

    1. Hi Ricardo,
      Sorry for not replying your message earlier. I never tried in lan setup before so I couldn’t comment on your questions. However, I guess the xml modification should be on the side with the FIPs connected.
      Tom

      Liked by 1 person

      1. Hi Tom!
        It worked! I put the xml file only in the slave machine.

        Steps:

        1 – Started the fsx on the master machine with the FSX SDK matching the fsx version and with the file c:\users\[USERNAME]\AppData\Roaming\Microsoft\FSX\SimConnect.xml:

        SimConnect
        SimConnect.xml
        False

        False
        IPv4
        global
        [LAN IP ADDRESS OF THIS MACHINE]
        64
        747
        4096
        False

        2 – After the fsx was started in the master machine I run C:\Program Files (x86)\Saitek\DirectOutput\SaiFlightSimX.exe with simconnect installed (it can be found in the lib SDK folder, with a file in C:\Users\[USERNAME]\Documents\SimConnect.cfg:

        [SimConnect]
        Protocol=IPv4
        Address=[LAN IP ADDRESS OF THE MASTER MACHINE]
        Port=747
        MaxReceiveBuffer=4096
        DisableNagle=0

        3 – Plug in the usb HUB that contains all instrument panels in the USB port.

        After all these steps I can run my six instrument panels on a slave machine using simconnect and all of them start in the order defined in the xml file. It´s important recognize the order that the HUB ports are ordered in at the startup by windows.

        Thank You!

        Like

      2. Hi Ricardo,
        Just found your reply in the spam folder. It was filtered by WordPress.
        Good instruction and I will give it a try.
        Sorry about the delay.
        Tom

        Like

  3. Great tutorial, Is it possible to completely Remove Saitek Product Images? Mine are showing up between the Altimeter and Cessna Airspeed panels. I hope I get a reply, I see this post is quite old.

    Like

  4. Hi Tom et. al.:

    I know this is not exactly the right place for my question, but I have been looking for answer and I hope someone could help.

    I have a Saitek FIP, and DirectOutput is working (as it displayed the sample jpg’s). However, I can’t get FSX to recognize panel (When I start any mission, the FIP still cycling through the sample jpg, not the instrumentation. I updated the exe.xml to point to the SaiFlightSimX.exe already. Any suggestions? This is the exe.xml. Please help. Thanks,


    Launch
    exe.xml
    False
    False


    Saitek Panel(s) Plugin for FSX
    False
    C:\Program Files (x86)\Saitek\Pro Flight Panels\SaiPanels.exe
    -run


    Saitek DirectOutput RadioStack
    False
    C:\Program Files (x86)\Saitek\DirectOutput\SaiFlightSimX.exe
    -run

    Like

    1. Hi Norman,
      Sorry couldn’t reply to you earlier. Your exe file seems to be ok.
      Have you checked the content of your SaiFlightSimX.xml file as well (C:\Program Files (x86)\Saitek\DirectOutput)? It is the key file in which gauges are pointed.
      Read my Post 187 (https://fsxtimes.wordpress.com/2013/02/03/187-adding-new-gauges-to-fip/) about adding new gauges. Also, my Post 28, 29 and 30 talked about the FIP basics and installations. They should help as well.
      Email me if you need further assistance.
      Tom

      Like

      1. Thank you Tom. It turned out that it is the combination of my Anti-virus and Firewall blocked the access of the SimConnect. So for now, I have to run FSX with all of those turned-off in order to have the add-ons and FIP work correctly.

        Like

  5. Hi Tom,
    Just wanted to send a note of thanks for your comments addressing the order of the FIPs loading. With 7 of them, I was really getting tired of scrolling the different instruments to select the ones I wanted in the order I wanted. I incorporated your comments in the xml file and then procured a 9 port USB hub with a 5 amp power supply and three on/off switches controlling 3 banks each of the usb slots. Now, when I run FSX and THEN turn on the 3 switches, the FIPs come up in the order I want every time. I’ve been trading emails with SAITEK/MadKatz techs support on this for some time, and they just don’t seem to get it. But you nailed it! Thanks for the work you’ve done in this area.
    Best Regards,
    Ed Humphreys

    Like

  6. Turns out I too had a couple “rogue” panels that “jump the gun,” and don’t follow the startup order, but yea, verily was able to keep swapping plugs (an re-start from “square 1”) to get the panels to come up in the desired order. [Appears we’re dealing with race conditions here….probably caused by the various hardware, USB drivers and Saitek drivers.]

    Then further, found it was not necessary to delay turning on the powered USB hub, just delay the plugging in of the USB connector to the powered hub. I connected a manual USB selector AB switch between the powered hub and the PC, and keep it switched to the “disconnected” side until I start FSX, then switch to the “connected” side and the panels come in order.

    [We’ll see if Saitek adopts the XPlane10 drivers solution of saving the last selection by serial number, and being able to restore accordingly.]

    Like

    1. Hi Jim,
      Thanks for the feedback. You are right that it is not absolutely necessary to delay turning on the powered USB but my approach ensure an error-free startup. Nothing is absolute and perfect, right?
      Tom

      Like

  7. Tom, I figured out what I was doing wrong. As you said, you must start from the last port and not the first one. I also disconnected the USB hub from the back of the computer and decided to use one at the very front so it is easy to connect and disconnect. Once FSX was started, and that is the key to a consistant start up, I connected the USB and I watched each FIP start up. They started 3,2,1,6,5,4 everytime. Once you understand the startup order you can then go to the .xml file and put the gauges in the correct sequence. Now I do not have to adjust each gauge everytime. I hope to eventually have 10 FIP’s so I can be IFR equipped. Thank you for the help.

    Will you please send me a link to your custom gauges. Thank’s again.

    Like

  8. This is great, but only works when you have up to 6 FIPs. When I added additional FIPs [using a single 10 port USB hub], they no longer would come up in the SaiFlightSimX.xml order.
    Appears the XPlane10 driver remembers last mode based on serial number, and I’ve requested Mad Catz tech support to forward that info to the Saitek driver folks.

    Like

    1. Hi Jim, I got 2 FIPs in the beginning and then growing up to 7 FIPs. I can manage to have them coming up in the sequence I want. It’s been discussed in my previous post which I don’t remember which one. You could search my posts regrading FIPs I guess.
      The quick solution is: Plug your FIPs into a single powered USB hubs. And remember that you must plug in the USB hub to your system ONLY AFTER FSX is loaded. This will ensure the gauges to start up in the order you set.
      Since it’s been a repeating issue to many flightsimmers using FIPs, I’ll write a new Post about it again to explain how I did it when time allows.
      Let me know if Mad Catztech gives you an answer.
      Tom

      Like

  9. Tom, great site. I am really enjoying looking through it. I have just built a Saitek cockpit with 6 FIP’s so far. I read the instructions above to change the start up order. It works great until I reboot. It seems the USB ports start in a different sequence on each boot up. Do you have any suggestions? It does get close so I can always just change each FIP to the correct gauge but it would be nice to have the correct gauges in the correct location when I start FSX. Thank you for you help. Dave

    Like

    1. Hi Dave,
      It’s been discussed in my previous post which I don’t remember which one. You could search my posts regrading FIPs I guess.
      The quick solution is: Plug your FIPs into a single powered USB hubs. And remember that you must plug in the USB hub to your system ONLY AFTER FSX is loaded. This will ensure the gauges to start up in the order you set.
      Since it’s been a repeating issue to many flightsimmers using FIPs, I’ll write a new Post about it again to explain how I did it when time allows.
      Tom

      Like

  10. Just a note about removing the product images. It doesnt matter the name of the image or the dimensions of the images. Also I dont know the limit of images you can put in there but I’ve put up to 20 and itll scroll through them all.

    Like

  11. Hello Tom. I’m having trouble applying this tweak. When I go to save over the existing file with the new changes, I get an error message telling me I’m not allowed to do that. Can you please advise? Also could I get a copy of your gauges emailed to me.

    Thank you

    Like

    1. Hi Dustin, sounds like to me that your windows setting doesn’t allow rewritting the file. You may change that via Windows settings. Or you can make a copy of the file and then rename your original file. Then make changes to the new one. This may help. Tom

      Like

  12. Hi Tom,

    Many thanks for a very helpful post. I’ve got another question, if you don’t mind; I’ve got nine Instrument Panels (six ‘normal’ scan pattern, 2 vor and 1 engine instruments and can’t get the file to ‘save’ the setup when I exit. I emailed Saitek support to be told the way to fix this was to set up a separate box to run the panels and connect with Ethernet!?

    Do you know of any other way to do this? If not, can anyone who has tell me what spec the ‘other’ box needs to be?

    Many thanks in advance,

    Ron

    Like

    1. Hi Ron,
      Don’t understand what you meant by “can’t save the setup” and “separate box”. Can you explain clearly?
      I have 7 FIPs and I don’t have any problem using them.
      Make sure your SaiFlightSimX.xml (under C:\Program Files (x86)\Saitek\DirectOutput) and gauge files are properly saved.
      Tom

      Like

      1. Hi Tom,
        Sorry, had a few health problems and lost this thread. What I meant is, I’ve got 8 gauges – the ‘standard six’, one for instruments, and one for VOR. If I edit the XML accordingly, it doesn’t get applied when I restart. As I said, I emailed Saitek, twice, and got told to set up a ‘server’ to handle the panels, per the instructions in the manual. I’m afraid my politeness went downhill when told their programmers can’t be bothered to handle a loop for more than six things (my supposition) and wanted me to take up valuable room in my ‘office’ for another pc – as well as the power and heat.
        Many thanks for your advice,
        Kindest Regards,
        Ron

        Like

  13. Hi Tom,
    Is it possible the the gauges from 64 bit and 32 bit shows up in the FIP, It seems to me the they’re more gauge when I scan for a gauge. I did notice the Direct Output for Saitek is in both Program Files and Program Files(x86) is this what cause it? I also noticed that the background images are in the Program File/Saitek/Direct Output but not in the X86 one.

    ????? a bit confused???? lol
    Mario

    Like

  14. Me again:

    Oops, there is lost a part of my comment. Instead of “(A:Airspeed select indicated or ture, knots) should be written:

    (A:Airspeed select indicated or true,knots)

    Thanks
    Thomas

    Like

    1. Hi Thomas,

      Don’t quite understand your question. But do you mean: your new gauge doesn’t show up on your FIP ?

      1)
      Have you added your new gauge’s xml file to the SaiFlightSimX.xml?

      In the SaiFlightSimX file, you should find something like the following:

      You have to add a similar command section for your gauge. Or you can just replace any existing one with yours.

      You can find more information about it in my Post 28.

      2)
      Have you tried the up/down arrow keys on the FIP to see if your gauge is in a different position?

      3)
      If you have only created the two bmp files, then you have to replace Saitek’s original bmp files with yours in the Airspeed.xml file (or something similar on your computer) in order to have them showing up on the FIP.

      Hope above helps.

      Tom

      Like

  15. Hallo Tom

    Im trying to add my own gauge for the FIP. To the SimFlightSim-File I have added the following line:

    In the Gauges-Folder I’ve saved two files:
    LAMAX_airspeed_background and LAMAX_airspeed_needle as bmp-files

    The LAMAXAirspeed-file looks like this at the moment:

    (A:Airspeed select indicated or true,knots)

    The values of the aren’t sure at the moment. I think I have to correct them later. I just want to control, if the gauge ist showing up at the FIP, but it doesn’t work. The FIP is showing only the regular gauges, but not mine.

    Do you have any idea or explanation, what I’m doing wrong?

    Thank you for your help…

    Thomas

    Like

  16. Hi Tom,
    I’m building a 172 MIP with Saitek gears. Can you send me the gauges file for the instrument panel. Love your blog lots of cool info, I changed my knobs on the two radio panel and the multi panel works great!! easier to turn. I’m also building my own GPS external panel with a 5.6″ screen with working buttons.
    I was also reading your post on the instrument panel will try that too.
    Keep up the good work!!!

    Like

    1. Hi Manny, Recommend you to look into Saiek’s Instrument Panel Forum. There are many information about gauge building. You can pick something similar or ask for help there.

      Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s